.Net 2.0 error reporting

Discussions about using SIP Sorcery on your own computer/server
jvwelzen
Posts: 716
Joined: Thu Sep 11, 2008 1:56 pm

.Net 2.0 error reporting

Post by jvwelzen » Fri Feb 26, 2010 6:11 am

Hi Aaron

Sometimes the SS service stops suddenly and I see an error in the event viewer

EventType clr20r3, P1 sipsorcery-appsvr.exe, P2 1.0.0.14617, P3 4b726933, P4 system, P5 2.0.0.0, P6 4889de7a, P7 2be7, P8 18, P9 system.objectdisposedexception, P10 NIL.

Do you maybe knows what is causing this

Thanks in advance

User avatar
Aaron
Site Admin
Posts: 4563
Joined: Thu Jul 12, 2007 12:13 am

Post by Aaron » Fri Feb 26, 2010 10:03 am

Nope no idea. The error.log file in the sipsorcery-appsvr.exe directory logs all errors though so there should be a corresponding entry in it at the same time with more information.

jvwelzen
Posts: 716
Joined: Thu Sep 11, 2008 1:56 pm

Post by jvwelzen » Fri Feb 26, 2010 5:38 pm

No the error.log file is empty tha latest errors where yesterday

this is the last piece of the root.log file

But it's seems to be all ok

Code: Select all

2010-02-26 09:01:19,781 [sipchanneludp-7490] DEBUG sipregistrar [(null)] - Bad register request, no Contact header from udp:127.0.0.1:5060.
2010-02-26 09:01:19,791 [sipchanneludp-7490] DEBUG sipregistrar [(null)] - Bad register request, no Contact header from udp:127.0.0.1:5060.
2010-02-26 09:01:19,801 [sipchanneludp-7490] DEBUG sipregistrar [(null)] - Bad register request, no Contact header from udp:127.0.0.1:5060.
2010-02-26 09:01:19,811 [sipchanneludp-7490] DEBUG sipregistrar [(null)] - Bad register request, no Contact header from udp:127.0.0.1:5060.
2010-02-26 09:01:19,841 [sipchanneludp-7490] DEBUG sipregistrar [(null)] - Bad register request, no Contact header from udp:127.0.0.1:5060.
2010-02-26 09:01:19,871 [sipchanneludp-7490] DEBUG sipsorcery [(null)] - re: Register queued for sip:31357123352@sip.huizenwireless.nl.
2010-02-26 09:01:20,011 [sipregistrar-core1] DEBUG sipregistrar [(null)] - UpdateBinding sip:31357123352@83.87.192.20:33971;uniq=63293C24E49DE6AF8E32E6F1B34F8.
2010-02-26 09:01:20,141 [sipregistrar-core1] DEBUG sipregistrar [(null)] - sip:31357123352@83.87.192.20:33971;uniq=63293C24E49DE6AF8E32E6F1B34F8 matched sip:31357123352@83.87.192.20:33971;uniq=63293C24E49DE6AF8E32E6F1B34F8.
2010-02-26 09:01:20,141 [sipregistrar-core1] DEBUG sipsorcery [(null)] - re: Binding update request for 31357123352@huizenwireless.nl from udp:83.87.192.20:33971, expiry requested 1800s granted 113s.
2010-02-26 09:01:20,251 [sipregistrar-core1] DEBUG sipsorcery [(null)] - re: Binding database update time for 31357123352@huizenwireless.nl took 110.1584ms.
2010-02-26 09:01:20,261 [sipregistrar-core1] DEBUG sipsorcery [(null)] - re: Binding update time for 31357123352@huizenwireless.nl took 250.36ms.
2010-02-26 09:01:20,261 [sipregistrar-core1] DEBUG sipsorcery [(null)] - re: Registration successful for 31357123352@huizenwireless.nl from udp:83.87.192.20:33971 (proxy=udp:62.145.70.50:5060), expiry 113s.
2010-02-26 09:01:20,261 [sipregistrar-core1] DEBUG sipsorcery [(null)] - re: register result=Authenticated, time=390.5616ms, user=31357123352.
2010-02-26 09:01:20,321 [regagent-1] DEBUG sipsorcery [(null)] - ra: Checking SIP Provider registration for Budgetphone-31357110469.
2010-02-26 09:01:20,341 [regagent-1] DEBUG sipsorcery [(null)] - ra: Sending initial register for 31357110469 and Budgetphone-31357110469 to udp:83.143.188.165:5060.
2010-02-26 09:01:20,442 [regagent-1] DEBUG sipsorcery [(null)] - ra: Initiating registration for 31357110469 on sip:sip1.budgetphone.nl.
2010-02-26 09:01:20,462 [regagent-1] DEBUG sipregagent [(null)] - Binding entry processing took 240.
2010-02-26 09:01:20,502 [77] DEBUG sipsorcery [(null)] - ra: Server response Unauthorised received for sip:31357110469@sip1.budgetphone.nl and sip:31357110469@sip1.budgetphone.nl.
2010-02-26 09:01:20,612 [77] DEBUG sipsorcery [(null)] - ra: Server auth response Ok received for sip:31357110469@sip1.budgetphone.nl and sip:31357110469@sip1.budgetphone.nl.
2010-02-26 09:01:20,712 [77] DEBUG sipsorcery [(null)] - ra: Contact successfully registered for 31357110469 on sip:sip1.budgetphone.nl, expiry 60s.

jvwelzen
Posts: 716
Joined: Thu Sep 11, 2008 1:56 pm

Post by jvwelzen » Sun Feb 28, 2010 11:49 am

I intalled some latest updates for .net framework

and know it seems to be working ok

So If someone has the same problems be sure to get the latest updates from windowsupdate.com

jvwelzen
Posts: 716
Joined: Thu Sep 11, 2008 1:56 pm

Post by jvwelzen » Fri Mar 05, 2010 6:23 pm

Stil having some problems with the .net framework error

It has been running great for 5 days and now the problem is back again

Are there more people with the same problem

jvwelzen
Posts: 716
Joined: Thu Sep 11, 2008 1:56 pm

Post by jvwelzen » Sat Mar 06, 2010 4:30 pm

I found something on the webiste from microsoft that describes my problem I think

http://support.microsoft.com/kb/911816

Could this be causing my problem

User avatar
Aaron
Site Admin
Posts: 4563
Joined: Thu Jul 12, 2007 12:13 am

Post by Aaron » Sun Mar 14, 2010 10:28 pm

No that's unlikely to be the issue.

If part of the sipsorcery software is failing there should be something in the error.log.

Regards,

Aaron

jvwelzen
Posts: 716
Joined: Thu Sep 11, 2008 1:56 pm

Post by jvwelzen » Sat Mar 20, 2010 9:30 am

Hi Aaron

I still have the error 2.0 problem and I cannot figure out what is causiung this

The strange thing is that I never had these problems with version 1.1

Is there something new or changed in version 1.2 that maybe can cause this problem

I hope that someone can help me figure ou waht is causing this problem

User avatar
Aaron
Site Admin
Posts: 4563
Joined: Thu Jul 12, 2007 12:13 am

Post by Aaron » Sat Mar 20, 2010 10:56 pm

Lots of things changed from local version 1.1 to version 1.2. Something should appear in the root.log or error.log file when the error occurs, you need to try and catch those files when it happens.

Regards,

Aaron

jvwelzen
Posts: 716
Joined: Thu Sep 11, 2008 1:56 pm

Post by jvwelzen » Sat Mar 20, 2010 11:06 pm

The .net frame error 2.0 happend at 13:40:04

and I found this in the log

at 13:39:16

Code: Select all

2010-03-20 13:39:16,247 [43] DEBUG NSsh.Server.SshSession [(null)] - Exception processing session: Object reference not set to an instance of an object.
System.NullReferenceException: Object reference not set to an instance of an object.
   at NSsh.Server.TransportLayer.State.ConnectedState.Process(ITransportLayerManager manager)
   at NSsh.Server.TransportLayer.TransportLayerManager.Process(Stream stream)
   at NSsh.Server.SshSession.Process()
2010-03-20 13:39:16,297 [43] DEBUG NSsh.Server.TransportLayer.TransportLayerManager [(null)] - Disconnecting 112.4.93.8:2182 with ProtocolError.
2010-03-20 13:39:16,317 [43] DEBUG NSsh.Server.TransportLayer.TransportLayerManager [(null)] - Stream was disconnected with ObjectDisposedException.
2010-03-20 13:39:16,317 [43] DEBUG NSsh.Server.TransportLayer.TransportLayerManager [(null)] - Exception closing client socket. Cannot access a disposed object.
Object name: 'System.Net.Sockets.Socket'.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest