Blank Page when using Firefox 3.6 and SilverLight

Discussions about using SIP Sorcery on your own computer/server
Post Reply
mgbfan78
Posts: 30
Joined: Wed Aug 19, 2009 3:44 am

Blank Page when using Firefox 3.6 and SilverLight

Post by mgbfan78 » Sat Mar 06, 2010 4:32 pm

When trying to access Local Sipsorcery with Firefox, rather than getting the login page at: http://localhost:8080/sipsorcery.html, all I get is a black page.

At first I suspected it was probably my FF setup as I run in slightly paranoid mode with most things disabled.

So, I made sure that JavaScript and Java were enabled. Then, I checked for Silverlight. It was there but an old version. So I uninstalled it, downloaded and installed the current version from MS and tried to access SS again. With the same result - a blank black page.

I fired up Google and found numerous references to FF not working correctly with Sipsorcery. But then one of the threads I was reading pointed out that the same results could be achieved without Silverlight. It has something to do with the way FF interprets 100% scaling on a /DIV tag. Rather than 100%, it instead scales to 0%. The workaround was to specify pixels instead.

Aaron, since I am not a web developer I was hoping you might take a look and see if there was a quick fix. Otherwise, we are stuck using IE to maintain SS Local.

Pat

User avatar
VoipDude
Posts: 39
Joined: Wed Oct 07, 2009 2:10 pm

Post by VoipDude » Sat Mar 06, 2010 11:51 pm

Same problem here Aaron.

The hosted version of SS works fine in FF, but the local version displays a blank page.

User avatar
Aaron
Site Admin
Posts: 4563
Joined: Thu Jul 12, 2007 12:13 am

Post by Aaron » Sun Mar 07, 2010 12:18 am

It's a known issue and has been added to the configuration guide.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest