No inbound or outbound audio on internal calls

Discussions about using SIP Sorcery on your own computer/server
Post Reply
nlaferle
Posts: 4
Joined: Sun Oct 17, 2010 6:41 am

No inbound or outbound audio on internal calls

Post by nlaferle » Mon Oct 18, 2010 12:12 am

Hi all --

Getting very close, but one last routing thing I can't seem to shake. External inbound and outbound calls work just great through GV and Gizmo. The issue is when I try and make a call between my subaccounts, which I am trying to set up in a way that would be comparable to a PBX-like world.

Basic topography:
3 SIP clients (PAP2 and 2 X-Lite) behind a NAT router (10.19.85.1) with SIP Sorcery running on another local machine (10.19.85.3). For the sake of illustration, we'll say my dyndns account is domain.dyndns.org mapped to public IP 71.71.71.1. My SIP clients are logged in as laptop@domain.dyndns.org and landline@domain.dyndns.org, respectively.

No matter how I fiddle with STUN and dial variations, I cannot get either inbound or outbound audio when I call from one 'extension' to the other. External calls, incoming and outgoing, work fine. Calls originate, ring and end as expected on the extensions. Inbound external calls forwarded by SS to these extensions also work fine.

I have tried the following from laptop@domain.dyndns.org to reach landline@domain.dyndns.org:
landline@local
landline@domain.dyndns.org
landline@10.19.85.3
landline@10.19.85.4 (the PAP2 IP address)
landline@10.19.85.1:5060 (the router address that shows as the Contact URI in SS)
Mapping speed dial 001 to landline@local and landline@domain.dyndns.org

Ironically, every one of these will ring the phone and make a connection. SS shows nothing awry. However, neither side can hear the audio from the other.

The only thing that I think might be a bit strange is that the contact URI for both clients behind my router actually is my router IP address: one shows landline@10.19.85.1:5060 as the contact URI and the other shows abcdefg@10.19.85.1:61082 as the contact URI. Both seem to be working, but I would have thought the actual IP address of the SIP client would have shown up there. Is my router somehow messing with the packets?

User avatar
Aaron
Site Admin
Posts: 4563
Joined: Thu Jul 12, 2007 12:13 am

Re: No inbound or outbound audio on internal calls

Post by Aaron » Mon Oct 18, 2010 1:30 am

There are two options you can use both of which stop the sipsorcery server from mangling the IP address in the SDP:

1. There is a setting called Network Id on SIP accounts. Set that the same for each of the accounts you are using behind the same NAT,
2. In your dial string add [ma=false], for example sys.Dial("localuser@local[ma=false]").

nlaferle
Posts: 4
Joined: Sun Oct 17, 2010 6:41 am

Re: No inbound or outbound audio on internal calls

Post by nlaferle » Mon Oct 18, 2010 2:09 am

Thanks! Setting the Network ID for all accounts fixed it.

Will that impact my ability to make calls between those subaccounts if one logs in from outside the NAT? Just curious.

User avatar
Aaron
Site Admin
Posts: 4563
Joined: Thu Jul 12, 2007 12:13 am

Re: No inbound or outbound audio on internal calls

Post by Aaron » Mon Oct 18, 2010 2:19 am

It won't affect the ability to make calls but it will potentially result in audio problems. It will depend on whether your SIP devices are putting private IP addresses in their call requests or not. The tricky thing is when they all on the inside of the same LAN you want private IP addresses but if the call parties are on different LANs you want the public IP address or to let the sipsorcery server do some mangling.

If a device is moving around a lot you could add some logic to your dialplan that could tell whether it was on your home LAN or not and then apply the [ma=false] dial string option.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest