SIP provider's settings for multifon service

Getting started with the SIP Sorcery
Post Reply
sab
Posts: 1
Joined: Tue Nov 24, 2009 9:04 am

SIP provider's settings for multifon service

Post by sab » Tue Nov 24, 2009 12:33 pm

Hi all

I just only begin to use SS for sip routing and found out one great difficult for one provider. It requires not usual settings. I looked up about this on my local forums and found some recomendations for TrixBox settings which are work. Look at them below:

In sip_custom.conf you have to allow tcp:
Code: tcpenable=yes

Put settings via freepbx:
Trunks->Add Trunk->Add SIP Trunk

Trunk Name:
Code:multifon.ru

PEER Details:
Code:
type=friend;
host=sbc.megafon.ru
host=193.201.229.35
username=7926XXXXXXX
secret=Password
insecure=very
fromdomain=multifon.ru
fromuser=7926XXXXXXX
disallow=all
allow=g729&ulaw
qualify=yes
transport=tcp
nat=never
dtmfmode=inband

Register String:
Code:
tcp://7926XXXXXXX@multifon.ru:Password:7926XXXXXXX@sbc.megafon.ru/7926XXXXXXX


So, how could I realize thease by SIPSorcery Provider's fields?

Now I made the following setting:

Provider name:Multifon
Username:7926xxxxxxx
Password:xxxx
Server:sip:sbc.megafon.ru
Register:yes
Register contact:sip7926xxxxxxx@multifon.ru
Outbound proxy:sbc.megafon.ru
Register realm:multifon.ru
Register server: sip:7926xxxxxxx@sbc.megafon.ru:PASSWORD;transport=tcp


It provides registration on server but I'v got 403 Forbidden for outgoing calls.

Please, any ideas

Regards, sab

Evgen
Posts: 17
Joined: Fri Feb 15, 2008 7:32 pm
Location: Russia

Re: SIP provider's settings for multifon service

Post by Evgen » Wed Oct 20, 2010 9:43 am

Did you have any success?

AndrewZ
Posts: 19
Joined: Thu Nov 13, 2008 10:03 pm

Re: SIP provider's settings for multifon service

Post by AndrewZ » Mon Nov 08, 2010 11:19 am

sab wrote: It provides registration on server but I'v got 403 Forbidden for outgoing calls.
Do you have incoming calls working with this provider?

ikiselev
Posts: 1
Joined: Tue Oct 27, 2015 8:33 am

Re: SIP provider's settings for multifon service

Post by ikiselev » Tue Oct 27, 2015 8:41 am

Looks like something broken in SipSorcery/Multifon connection.
I try to check if something was changed, but for last three years it is broken.
My current setup:
Username: 792...
Server: sip:sbc.megafon.ru:5060
Realm: multifon.ru
Auth Username: 792... (Same as username).

It is able to register, but neither inbound, nor outbound calls passed. When I try to do inbound call from other phone, Megafon answers something like "Number doesn't exist".

Looks like this problem could be resolved only with server-side logs access.
It works from any other SIP client/service that I tested.
Maybe @AAron will take a look on it sometime? What info should I provide for it?

User avatar
Aaron
Site Admin
Posts: 4560
Joined: Thu Jul 12, 2007 12:13 am

Re: SIP provider's settings for multifon service

Post by Aaron » Wed Oct 28, 2015 9:18 am

You can obtain server side logs from the sipsorcery service by using the Console as described here http://www.sipsorcery.com/mainsite/Help/Console (note if you can't use the SIlverlight portal the Console is also available in the normal web login).

If you are trouble shooting a problem with a call the Console filter to use is: event full and request invite

Once set place your call and you will get a full SIP trace.

If you are getting an error message like "number doesn't exist" perhaps you are using the wrong prefix for international calls or something similar.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest