SIP Registration with Anveo drops prematurely?

Found something wrong ?
Post Reply
PaulC
Posts: 4
Joined: Mon Nov 10, 2014 3:55 am

SIP Registration with Anveo drops prematurely?

Post by PaulC » Sat Jul 04, 2015 10:47 pm

I've been getting 'offline' status alerts from Anveo for the past few days, claiming that SipSorcery's registration expired without being renewed.

If I check immediately after receiving one of these alerts, Sip Sorcery thinks it is registered with Anveo, Anveo doesn't. The situation rectifies itself the next time SipSorcery renews its registration. When I force SipSorcery to re-register, it resolves itself, too. The symptom almost seems like SipSorcery thinks the registration has a timeout that's much longer than Anveo thinks it is.

This isn't happening consistently, perhaps two or three times per day. 'Registry Expiry' on the SipSorcery end is set to 3600. Anveo does not provide a consistent value in the config examples they provide. I'll open a ticket with them to find out what the official value is, and post a follow-up.

For now, I'm just going to shorten Registry Expiry to work around this. But thought I should mention it, as it had been working fine up until a few days ago.

- Paul

PaulC
Posts: 4
Joined: Mon Nov 10, 2014 3:55 am

Re: SIP Registration with Anveo drops prematurely?

Post by PaulC » Sun Jul 05, 2015 2:18 am

Anveo support wrote: Alert is sent when 10 minutes has passed since the last registration expiration and no new registration was sent.

The most common registration timeout is 180 to 360 seconds

User avatar
Aaron
Site Admin
Posts: 4551
Joined: Thu Jul 12, 2007 12:13 am

Re: SIP Registration with Anveo drops prematurely?

Post by Aaron » Sun Jul 05, 2015 9:43 am

Thanks for the info. I've checked the server but everything looks fine. I'll keep an eye out.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest